Skip to main content
Call us
  • Support Auckland: 9:00am~2:00am Monday~Friday(09) 975-9407
  • Support Countrywide (landline only) 9:00am~2:00am Monday~Friday0800 441 995
Phone numbers and hours
Help Center

Explore our online help resources

Help

Managed WordPress Help

WordPress version 5.6 issues with jQuery

WordPress is updating and improving how the app works. On August 12, 2020 WordPress 5.5 was released as the first phase of the plan. Sites that relied on older jQuery went down due to the removal of jQuery Migrate 1.x library. The jQuery Migrate library allows plugins and themes using older versions of jQuery to function. These older versions contain Denial of Service(DoS) and Cross Site Scripting(XSS) vulnerabilities.

WordPress released a plugin named Enable jQuery Migrate Helper to restore functionality to sites broken by the version 5.5 change. This plugin will need to be updated when WordPress 5.6 is released. Sites that currently rely on this plugin to continue running older versions of jQuery will break again without an update.

What version of jQuery will come bundled with WordPress 5.6?

WordPress 5.6 will release bundled with jQuery library version 3.5.1.

What should I do?

If you installed the plugin Enable jQuery Migrate Helper plugin to solve issues after the release of WordPress 5.5, plan to update it and your other plugins and themes.

When should I expect WordPress 5.6 release?

The target release date for WordPress 5.6 is December 8, 2020. You can find more details at make.wordpress.org.

Community Related

joeelectronics's Avatar
Wordpress Managed PHP Version

155 Replies

Last posted over 2 years ago.

takyar's Avatar
PHP version is too low for WordPress

2 Replies

Last posted almost 2 years ago.

nathanmarkley's Avatar
Updating php and mysql version?

2 Replies

Last posted over 4 years ago.

Jordi's Avatar
PHP update

2 Replies

Last posted over 4 years ago.

Don't see what you are looking for? Search the Community