Mysql Workbench Connection

Hello everyone, i am really annoyed because i can not connect my mysql database to mysql workbench.

i can not find anyway , i have tried every single method from youtube and godaddy community.

 

What i think is i can not fill the required information correctly.

 

I Choose Standard TCP/IP Over SSH In Workbench.

I Fill this information :  

 

SSH Hostname : www.mywebsitedomain.com

SSH Username : Godaddy account username

Mysql Hostname : 127.0.0.1

Mysql Port : 3306

Username : username that i created for the database.

 

I Click on test connection

 

it says please enter the password for the following service.

 

Service : ssh@www.mywebsitedomain.com

Username : SSH Username

 

i enter the password for My godaddy account, i have also tried entering cpanel password and also database user password none of them work.

 

It says

 

failed to connect to Mysql at 127.0.0.1:3306 through ssh tunnel sshusername@www.mywebsitedomain.com with user Database username.

 

cannot open ssh tunnel : error connecting ssh tunnel : error connecting to ssh server [errorno : 11004]

getaddrinfo failed

Please refer logs for details.

 

 

Can anyone help me out please?

 

Community Team
Community Team

Have you already made sure SSH is enabled on that hosting plan?  Check out these instructions and make sure you can successfully connect via normal SSH: https://uk.godaddy.com/help/enable-ssh-16102?.  

 

If SSH is enabled and you're still getting that error, please reach out to our live support teams for further assistance.  Thanks.  

 

MPC