cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

Set up email with CPanel

Hi,

 

I have a new GoDaddy account with Domain and CPanel hosting. I can not sem to get the cpanel email to work. There seems to be the DNS and MX records not configured correctly. I would assume these would auto configure. The helpdesk tells me they do not support setting this up (seems silly not to support a product that sold be GoDaddy). I can not find default setting anywhere. Can anyone guide me what the DNS (A record, CNAME recond, MX records and SPF records need creating are where I add them please.
Thanks in advance.

4 REPLIES 4
Super User III
Super User III

Re: Set up email with CPanel

@BarnyP 

Your main @ A record should be the up address of the server

You can setup a CNAME for www which points to @

I  suggest setting up an A record for mail which points to the up of the server

then set up the MX record for @ pointing to mail



I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

New

Re: Set up email with CPanel

Hi PL281, thanks for the reply. In cPanel, the mail server is this:

sg(contents hidden)0046.prod.sin2.secureserver.net

However my website it is:

www.cruiserview.com.au

There is no MX record on the GoDaddy default install (which is quite disappointing, and the help desk has been no real help). Do I add the MX record in cPanel (using the Zones app) or on the GoDaddy DNS Management screen (which I presume overrides cPanel). And what should I add?

All my other website are with Netregistry who auto-configure the MX record and do not use the secureserver.net as a mail server for cPanel.

Super User III
Super User III
Solution

Re: Set up email with CPanel

@BarnyP 

 

You should use the GoDaddy DNS Manager - Unless you've set up custom HOSTS for your domain which would be the only way to use the cPanel DNS.

 

I assume your domain is cruisereview.com.au (it was missing an E with what you posted) 

That being said. As per my original post

1) A record = Host = mail Points to  = 166.62.28.130 TTL = Custom / 600

2) MX record... Host = @ points to = mail.cruisereview.com.au TTL = Custom / 600



I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

New

Re: Set up email with CPanel

Thanks PL281. I have set the DNS settings as per below (IP address's have been redacted). This seems to be working.

 

A@166.......10800 secondsEdit
Aadmin166.......10800 secondsEdit
Amail166.......1/2 HourEdit
CNAMEautoconfig@1 HourEdit
CNAMEautoconfig.admin@1 HourEdit
CNAMEautodiscover@1 HourEdit
CNAMEautodiscover.admin@1 HourEdit
CNAMEcpanel@10800 secondsEdit
CNAMEwebdisk@10800 secondsEdit
CNAMEwebdisk.admin@10800 secondsEdit
CNAMEwhm@10800 secondsEdit
CNAMEwww@10800 secondsEdit
CNAMEwww.admin@10800 secondsEdit
CNAME_domainconnect_domainconnect.gd.domaincontrol.com1 HourEdit
MX@mail.cruisereview.com.au (Priority: 0)1 HourEdit
NS@ns41.domaincontrol.com1 Hour 
NS@ns42.domaincontrol.com1 Hour 
SOA@Primary nameserver: ns41.domaincontrol.com.1 Hour 
TXT@v=spf1 a mx ptr include:secureserver.net -all1 HourEdit
TXTadminv=spf1 a mx ptr include:secureserver.net -all1 Hour