• GoDaddy Community
  • Websites + Marketing | Website Builders
  • Websites + Marketing | Website Builders

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution

    SEO image alt text issues

    Hello, I am not sure of all of the places in Website Builder where one can enter image alt text?  When I run the SEO wizard, it seems only a small portion of images from my site are selected for alt text. And out of those,  about half of those show the alt text on the web site under the image and the other half is hidden from the UI, which is the correct behaviour.

     

    For example, the alt text shows for this image on top right: https://accuratesound.ca/testimonials

    That should be hidden from the UI.

     

    Whereas, on this page the 3 x 2 row of images, all have alt text, but hidden in the UI:

    https://accuratesound.ca/services

     

    1) Where do I enter the alt text for the rest of the images that the SEO wizard does not pick up?

    2) Is it a bug that half the alt text entered is showing up in the UI and the other half is hidden?

    Thanks.

    Kind regards,

    Mitch

     

    1 ACCEPTED SOLUTION

    Accepted Solutions
    Rockstar II Rockstar II
    Rockstar II
    Solution

    Re: SEO image alt text issues

    @Mitchco 

     

    For images that you upload and galleries that your create, when you click on each image while in the editor, that image's "current image" settings appear in the sidebar.  That is where there is a box "Describe this image" where you can input your alt text.

     

    Is text in those boxes?  If so, then I would have to assume the wizard is not picking up on that for some reason.

     

    You can double-check from the front-end of your site as well by going to a page then right click/view source to see if the alts are in fact in the page code.

     

    Does that help? 😉

    Judith
    "It's hard to beat a person who never gives up." ~Babe Ruth

    View solution in original post

    3 REPLIES 3
    Rockstar II Rockstar II
    Rockstar II
    Solution

    Re: SEO image alt text issues

    @Mitchco 

     

    For images that you upload and galleries that your create, when you click on each image while in the editor, that image's "current image" settings appear in the sidebar.  That is where there is a box "Describe this image" where you can input your alt text.

     

    Is text in those boxes?  If so, then I would have to assume the wizard is not picking up on that for some reason.

     

    You can double-check from the front-end of your site as well by going to a page then right click/view source to see if the alts are in fact in the page code.

     

    Does that help? 😉

    Judith
    "It's hard to beat a person who never gives up." ~Babe Ruth

    View solution in original post

    Re: SEO image alt text issues

    Thanks for your response. It seems the SEO wizard is picking up less than 50% of my images on the site. Here is an example of an image that was not picked up by the SEO wizard:

     

    SEO wizard not picking up images.jpg

     

    So I enter the alt text and publish the site. And this one works as it should i.e. the alt text is not visible:

    SEO image alt text working properly.jpg

     

    However, choosing another image and adding the alt text results in the alt text actually showing on the website, which is wrong as it should be hidden:

     

    SEO image alt text should not be showing in the site.jpg

     

    So it seems I can resolve the one issue and not use the SEO wizard and simply add the image alt text. Great. However, it appears random if the alt text shows with the image or not. It should not show at all. Does not look professional on the site. This seems like a bug...?

     

    Kind regards,

    Mitch

    Re: SEO image alt text issues

    Spending some time it still appears that a) the SEO wizard does not recognise the majority of images on my site and b) for the ones that it did, it seemed to put the text in the "caption" field instead of the "describe this image" field. I also goofed on a couple where I did that manually as the caption field and describe this image field are stacked one on top of the other and I typed in the wrong field.

     

    Manually going back and making sure I was using the "describe this image" field, I have been able to add alt text to every image correctly (Not using the SEO wizard).

     

    I would suggest not using the SEO wizard as it does not seem to pick up all of the images and there may be a bug where the text is put in the wrong (i.e. caption) field.

     

    @Muse Thanks for your help!

     

    Kind regards,

    Mitch