Skip to main content
Help Center
The GoDaddy Community will undergo maintenance starting on Tuesday, August 3rd at 3pm PST / 6pm EST. Learn more
  • GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 

    network unreachable after patch

    I have a self-managed virtual private server, which has been running for 1 1/2 years without problems.


    Last Wednesday, GoDaddy patched the server and restarted it. Since then the server has been unable to make outbound connections outside of the GoDaddy domain. For example I can ping but not an outside web site. curl to any http or http site other than returns "network is unreachable". traceroute goes through several GoDaddy hops but then records a series of ***


    inbound ssh and https work fine.


    It seems to me that there is a mis-configured router outside my control. It isn't a firewall issue, because otherwise I could not ping or curl Godaddy.



    Where do I go from here? I have tried but phone and chat support, and both representatives not only said they could not help, but refused to connect me with somebody who could.

    Can anybody here help? I'm almost certain it is a Godaddy infrastructure issue but there

    seems to be no way to get it addressed. This has turned into a Kafka-esque nightmare.




    2 REPLIES 2
    Super User I

    Hello @unixvet and welcome to the community. I'm a GoDaddy customer like yourself. 


    Yeah, I saw where they were doing updates on my Linux VPS/hosting server. I have to admit that I didn't have any issues with my LInux VPS. 


    I'm curious, when you did your ping and tracert, what was the IP that it return for


    What are you running for your firewall on your VPS? IPtables? UFW?


    What are your results if you run 'ifconfig' in a SSH session? You should see an 'etho' interface or something similar with your public IP to the server. 


    Mabye with that above information, we might be able to pinpoint the issue. 

    Very Respectfully,

    Drew Davis
    Navy Veteran and Entrepreneur | GoDaddy Pro user | "Proud to be serving others!"

    *** Please note that I offer free advice on this forum. Please feel free to give me KUDOS on this topic/discussion; mark my comment as ACCEPTED SOLUTION if you believe I've helped solved your issue. Thanks! ***

    Hi Drew. I ended up using the nuclear option - backing up, re-provisioning and re-installing everything. After that, it worked.

    I did ifconfig and route -n before and after re-provisioning, and there were significant differences. Before re-provisioning there were ifconfig entries for vibr0: and vibr0-nic and virbr0 appeared in the routing table. After re-provisioning those entries were gone.

    My main concern is the total lack of support. I am fully aware that with a self-managed VPS I am responsible for administration, and having run UNIX servers for a very long time I am comfortable with that. But interface configuration needs information from the network people and that was impossible to obtain. I literally cannot afford to have my site down due to a failed patch and then spend several days unsuccessfully trying to contact somebody who could help. I will definitely not be renewing my subscription when it comes to an end.