• GoDaddy Community
  • VPS & Dedicated Servers
  • VPS & Dedicated Servers

    cancel
    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution

    IIS Application Pool - Idle Timeout

    Hello all,

    I'm new to Plesk.  I have an ASP.Net application that's deployed in a shared Windows hosting environment.  The application has very few users but the users need a lot of time to complete some of the online forms and can have long periods of no activity.  The application is "bumping" the users off after about 5 minutes of being idle.  When the user clicks a control on the page after 5 minutes of inactivity, they're redirected to the log in screen.

    It looks like there is a setting for Idle timeout (minutes) under IIS Application Pool, but the value looks uneditable.

    Tech Support recommended that I add some parameters and values to the user.ini file in the root folder of the website.  I tried adding some timeout type values (expect.timeout=-1, mssql.timeout=120, oci8.persistent_timeout=-1), but it didn't seem to change the values on this settings page. See the IIS Application Pool page screen capture.

    Has anyone been able to increase the Idle timeout?  If so how?
    Thank you.

    2 ACCEPTED SOLUTIONS

    I tried uptime robot and although it did work for the most part, i found that every so often when i checked my site, it took a while to load as i might have caught it at the time iis was restarting.
    A better site is pingdom.com. They do checks every minute and its free. So there's no chance iis will go to sleep. Also you can see a report with how long the responses take and they use servers from all over the world.

    View solution in original post

    While you cannot edit the IIS Application Pool Idle time on our Shared Hosting plans it is an option that can be changed within our Managed Virtual Private Servers & Managed Dedicated Servers.

    JessicaP

    View solution in original post

    13 REPLIES 13
    Moderator

    Hi @pemarti, thanks for posting.

    The time out for the worker processes/App Pool in the shared Plesk accounts cannot be changed. You may want to try using cookies or some other solution to storing session data so that sessions aren't lost if it time out is reached. Perhaps another Community member can offer some additional suggestions.

    ^Gary

    Gary - GoDaddy | Community Moderator
    24/7 Support | Check System Status

    Is there an account upgrade that can enable me to set the idle timeout i.e set it off. My plan is deluxe windows hosting with plesk.

    Where you able to increase the timeout? I'm facing the same issue.

    ever get an answer on this?

    I have got the same problem. I need the IIS Application Pool Idle timeout increased  to at least 15 minutes. The user needs to digest some information on the screen and 5 minutes is not a very good solution.  If that is not sorted out soon I will have to change my hosting. I already bought a hosting package with another provider for another project and after that will decide what to do. Shame because most of the tools provide on Godaddy are really good.

    This problem almost makes the webhost unusable. Who's dumb idea was it to set it to 5 minutes? 20 minutes should be the standard. 


    I haven't tried this yet but maybe there is a solution somewhere in doing this?

    1. (ping the server every 4 minutes to prevent idle timeout)

    https://stackoverflow.com/questions/36405535/how-to-change-idle-timeout-asp-mvc-app-on-my-shared-hos...

     

    2. (One way to ping the server)

    http://lostincompilation.co/2015/05/speeding-up-godaddy-shared-hosting/

     

    3. (Another way for asp.net) 

    https://stackoverflow.com/questions/5014052/how-to-pinging-domain-in-every-few-seconds-minutes-using...

     

    Regardless this question desperately needs a good answer.

    As far as I can tell none of these methods work.

    Just checking, is there any solution to this problem yet? I can't believe how inefficient this is.

    Hi guys, after searching an experimenting for some time, I have found a site which is able to solve this issue.

    You guys can go to uptimerobot.com and register for an ID. The free plan allows you to send http request every 5 minute interval, subsequently keeping your site from shutting down due to the 5 min idle timeout settings.

    I tried uptime robot and although it did work for the most part, i found that every so often when i checked my site, it took a while to load as i might have caught it at the time iis was restarting.
    A better site is pingdom.com. They do checks every minute and its free. So there's no chance iis will go to sleep. Also you can see a report with how long the responses take and they use servers from all over the world.

    View solution in original post

    How GoDaddy is handling this is ridiculous.  I called on this and they indicated the setting could not be changed and suggested I use some scripting to ping back my site to keep it alive.  Wow, how shortsighted.  Set a timeout that is to short and then tell customers to create scripts that will keep the site up thereby defeating their timeouts.  End result would be apps not coming out of memory and the server overloaded anyways.  Very disappointed that there is no support at all on this.  The suggestions here on ping tools are good but I'll be looking for a different provider.  Too bad I wasted several hours of my weekend migrating my site from the old hosting to plesk to try and solve my session lost issues only to find out that there is no fix here.

    This is really very inconvenient. My web application session time out is set to an hour as requested by my client but godaddy logs the user out in less than 10 minutes. This does not seem right. We should have the ability to control the timeout of our session.  

     

    Can someone please share the script? that will keep the session alive longer?

     

    Thanks in advance,

    While you cannot edit the IIS Application Pool Idle time on our Shared Hosting plans it is an option that can be changed within our Managed Virtual Private Servers & Managed Dedicated Servers.

    JessicaP

    View solution in original post