cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution

Video from Media Library not Showing Up on Site

I have tried half a dozen times to put a video on our home page. Go into Beaver Builder, insert a video block, select the video from the media library, save it, publish it. When I'm logged into WordPress and click "view," it shows up. But when I log out of WordPress and try to view the home page as a site visitor, there is just a large blank space. Any idea as to what could be going on?

 

The site is https://ccnwfl.org

 

 

1 ACCEPTED SOLUTION
Super User IV

@bprovost 

 

Hello from the other side of the state (Palm Beach County) -  I assume you are referring to the video on the homepage - which once clicked on does load - I would look to see if you can specify a "preview" image

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post

1 REPLY 1
Super User IV

@bprovost 

 

Hello from the other side of the state (Palm Beach County) -  I assume you are referring to the video on the homepage - which once clicked on does load - I would look to see if you can specify a "preview" image

I am a GoDaddy End User - Just Like You
Check out my site! | I currently manage over 300 WordPress Websites
* Please note that I offer free advice on this forum. Thank You Info If you would like personalized help, please contact me. Otherwise, please ask your question in the proper forum so the answer can assist EVERYONE in the community and not just you. Thanks! *

Once your issue is resolved,
please be sure to come back and click accept for the solution

Get Better Support on the Community Boards!
Etiquette When Asking for Help from the Community

View solution in original post