cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
New

The link you followed has expired.

Am getting this error when I try publishing new posts or even whenever am trying to update a post. similarly, I can't approve comments.

The link you followed has expired. Try again

1 ACCEPTED SOLUTION
Super User II

@brilea 

 

Two things could be at play.  Memory issues or a conflict.

 

For memory issues, if you are not familiary with these settings and the wp-config file, you would need to contact GoDaddy for support for assistance.

 

If increasing the memory does not resolve the issue, you most likely have a plugin conflict. 

Whenever WordPress does not behave as it should, that typically indicates a conflict of some sort. In most cases a plugin, and sometimes even your theme. We do this by process of elimination.


The best way to do all this testing without disrupting your live site is by using a staging environment if your plan comes with that option.


You can test this theory by disabling all your plugins and then see if the issue resolves itself. If it does, you know you have a plugin that isn't playing nicely with others. Reactivate one-by-one until the issue resurfaces and you know which plugin has to go.


Check that all your plugins are compatible and tested up to version 5.2. While some plugins will still work, by not having plugins that are not keeping up with WordPress you run the risk of conflicts.


If it isn't plugins, it could be your theme. You can run your situation by the developer (noting you already eliminated a plugin conflict) and ask if they are aware of any issues. Or, you can deactivate you theme and use the WordPress default Twenty Nineteen theme to see if the issue resolves. If it does -- you know it is your theme.

 

HTH! 😉

 

Judith
"No pressure, no diamonds." Thomas Carlyle

View solution in original post

1 REPLY 1
Super User II

@brilea 

 

Two things could be at play.  Memory issues or a conflict.

 

For memory issues, if you are not familiary with these settings and the wp-config file, you would need to contact GoDaddy for support for assistance.

 

If increasing the memory does not resolve the issue, you most likely have a plugin conflict. 

Whenever WordPress does not behave as it should, that typically indicates a conflict of some sort. In most cases a plugin, and sometimes even your theme. We do this by process of elimination.


The best way to do all this testing without disrupting your live site is by using a staging environment if your plan comes with that option.


You can test this theory by disabling all your plugins and then see if the issue resolves itself. If it does, you know you have a plugin that isn't playing nicely with others. Reactivate one-by-one until the issue resurfaces and you know which plugin has to go.


Check that all your plugins are compatible and tested up to version 5.2. While some plugins will still work, by not having plugins that are not keeping up with WordPress you run the risk of conflicts.


If it isn't plugins, it could be your theme. You can run your situation by the developer (noting you already eliminated a plugin conflict) and ask if they are aware of any issues. Or, you can deactivate you theme and use the WordPress default Twenty Nineteen theme to see if the issue resolves. If it does -- you know it is your theme.

 

HTH! 😉

 

Judith
"No pressure, no diamonds." Thomas Carlyle

View solution in original post