• GoDaddy Community
  • Managed WordPress Hosting
  • Managed WordPress Hosting

    Showing results for 
    Show  only  | Search instead for 
    Did you mean: 
    Go to solution
    Helper III
    Helper III

    Solution: SFTP Upload Issue with Managed WordPress

    Hi Everyone,


    Problem: Uploads Failing on PUT (SFTP)

    File uploads were consistently failing on file transfer to Managed WordPress hosting using SFTP protocol with FileZilla or Dreamweaver. The issue was so troublesome to diagnose, it took months to nail down so I thought to share the solution in case anyone else finds they are having the same issue.


    Wired & Wireless Reduced Power State

    The issue occurs both with hard wired & wireless NIC cards, the cause being the reduced power state the cards are placed into by the Windows OS power plan on their USB & PCI Express buses plus the device driver settings.  


    Solution:  The fix is to alter the power plan & device driver settings to prevent the NIC cards from entering a reduced power state so always allowing the NIC cards to properly negotiate uploading (PUT) files with the Linux GoDaddy server cluster using SFTP.


    Computer Setup

    • Windows 10 Pro OS (64 bit)
    • Desktop Intel i7-2600 CPU @ 3.40GHz
    • 12 GB RAM
    • Network Cards
      • Realtek PCIe GBE Family Controller NIC card (RJ45 connector, hardwired)
      • 802.11ac Wireless LAN Card (Netgear AC1200 High Gain WiFi USB Adapter)
    • NETGEAR Nighthawk X4S AC2600 Smart WiFi Router (R7800) - New replacement router
    • CISCO (Linksys) E4200 Router - Old original router
    • FileZilla & Dreamweaver CC (SFTP clients)


    Reduced Power State of NIC (Network Interface Card) 

    When your NIC card enters a reduced power state controlled by the NIC driver setting and the Windows OS power plan (USB & PCI bus settings) this for some reason messes up the upload functionality of SFTP, even as the download functionality works without problems.


    You can download files but not upload them, which drives you crazy...


    Symptoms of Upload Failure

    The SFTP client tries to upload (PUT) a file but a zero 0KB stub file name is instead created together with a temporary server side file in the format .nfcxxxxxxxxxxxxxxxxxxxxxxxx where x=various random numbers.  Once the temporary transfer file is created this breaks all further attempts to upload anything and it must be deleted from the server to enable transfers to continue.



    somefile.html - 10KB (local)   =PUT=>   somefile.html  - 0KB (server)

                                                   =====>   .nfc0903490243214324343243


    Temporary Fix

    If you disable then re-enable the network device under:

    Control Panel > Network and Internet > Network Connections > Disable this network device


    The upload functionality would start working for a while but after an hour or so would apparently randomly stop working.  I now know this is due to the device on its PCIe / USB bus being placed into a reduced power state when not in use by the operating system.


    Permanent Fix

    The settings you see for each device will depend on the device and its driver.



    Control Panel > Network and Internet > Network Connection


    For my wireless USB NIC card

    • Right click on the NIC card device
    • Properties > Configure > Advanced >  Selective Suspend > Disable
    • Properties > Configure > Advanced > Power Management > Allow the computer to turn off this device to save power (uncheck)

    For my hardwired PCI Express NIC card

    • Right click on the NIC card device
    • Properties > Configure > Advanced > Power Management > Allow the computer to turn off this device to save power (uncheck)



    • Control Panel > Hardware and Sound > Power Options
    • Balanced (recommended) > Change plan settings > Change advanced power settings
    • Wireless Adapter Settings > Power Saving Mode > Maximum Performance (battery & plugged in)
    • USB Settings > USB selective suspend setting > Disabled (battery & plugged in)
    • PCI Express > Link State Power Management > Off (battery & plugged in)



    Add into the mix I had my router setup with a "dial on demand" setting to the DSL modem which I changed to be "permanently connected" to reduce any potential for dropping connectivity during negotiation.  I did not confirm this was a definite contributing cause but mention in case it is relevant for someone else.


    What didn't work

    • Changing NIC cards, didn't fix the issue.
    • Reinstalling device drivers, didn't fix the issue.
    • Windows 10 reset all network connections, didn't fix the issue.
    • LAN connectivity, wireless versus hard wired, didn't fix the issue.
    • Changing routers, didn't fix the issue.
    • (The modem could not be changed being custom programmed by our ISP).
    • Using different SFTP clients, didn't make a difference.
    • Resetting the NIC device, temporarily fixed the problem.
    • Only by changing the power state options, was the issue permanently fixed.


    40 REPLIES 40
    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    The other weirdness was while the issues were happening with Managed WordPress I was able to upload securely using SSH and FTP (Dreamweaver & FileZilla) to our other GoDaddy hosting account.  Somehow the secure protocols were being negotiated differently between hosting servers and the NIC cards or the hosting servers have a different communications setup.


    The NIC cards were not coming out of the low power state fully (for some reason) and being able to negotiate and send via SFTP.  This was the strangest problem and nothing to do with bad router hops or internet connectivity for the issue continued during testing over several months.  If you reset the NIC card (disable/enable) then it would work on the same trace-route path a moment later.


    Hope this helps someone for it frustrated me for a long time.

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    The upload problem has returned and the solution previously provided no longer works.  I think there may be a more general underlying issue with file uploads to Managed WordPress hosting as indicated in the following post.




    The issue is duplicated on other computers in our company so less likely now to be individual operating system settings.  We do not have a permanent solution at this time but we do have a workaround that still functions.


    Disable the network adapter, allow it to fully disconnect then re-enable the network adapter.


    The file upload will then work for a period of time, maybe good for up to 30 minutes but it varies, where a moment ago it would not, on the same computer, router, modem, ISP and router hop Internet connection setup.  The only change is the network adapter reset.


    Different computers, different network adapters and device drivers... same issue.


    This assumes the temporary .nsf files have first been cleared.



    Re: Solution: SFTP Upload Issue with Managed WordPress

    Thanks for your extensive explanation. Do you have any ideas why this is happening only on Godaddy's managed WordPress hosting?


    I am using multiple hosts and FTP clients and never had an issue like this. Also, it seems the problem is confined only to larger files (multiple MB+). Transfer of small files works just fine.


    Btw, I managed to by-pass the issue by avoiding using a wireless connection. Connecting my laptop via a cable seemed to have worked.

    SFTP issues

    I have two problems.


    Using Filezilla:  software disconnects.  Changed settings, port 22, Here is the exact error:

    "Response: fzSftp started, protocol_version=8
    Command: open "e1973523596208@barrettjunctioncafe.com" 22
    Error: Network error: Software caused connection abort
    Error: Could not connect to server"


    Waiting on chat now, but do not get it.  We received an email mssg from Google the site had been hacked.  I checked the suspicious posts in WP, found nothing,  attempted to use Filezilla.  Yesterday was logged in for a minute through Filezilla after four attempts with the first error mentioned above.  Next four attempts same error.  Ran out of time, left it for today, hence the following issues mentioned. 


    Re: SFTP issues

    The real issue with GoDaddy SFTP is that their connections aren't capped at a reasonable rate. So if you connect and it starts downloading at 8 MB/s, it is gonna close the connection in an attempt to rate limit, I guess. Anyhow, if you cap your DL speed on your client to something reasonable, say 2 MB/s, the connection holds and downloads just fine.


    Re: Solution: SFTP Upload Issue with Managed WordPress

    I am having this same exact issue. What finally worked for me was disable/enable the NIC. I even called godday support and on their end it works just fine. I did more digging after the call and found your post. Since they cant reproduce the issue they kept saying on my end. Man this was like super frustrating just to modify one dam file. I even used winscp and another computer. Internet fine from work and home. both file transfer clients working fine. Its still not really resolved. It says the file didnt transfer but it does transfer. This makes no sense.


    Thanks for this post. It gave me some things to try even though it randomly works and then it stops again. I just have to keep disabling/enable the NIC to kinda make it work.


    Godday needs to look at this.

    Re: SFTP issues



    The fact that you posted this and GoDaddy has not realized it is the ACTUAL solution, and they highlighted that bogus explanation above that basically puts the fault on the client instead of their server settings is crazy to me. The least they can do is provide their clients with the right SFTP settings needed if the standard settings are not working like every other site. I tried what you suggested and it absolutely worked perfectly in Filezilla. Thank you for posting this.

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    This problem continues unfixed.  Various people made some good suggestions that I tried on my NETGEAR router.


    1. Setup port forwarding on port 22 from the fixed IP address of the computer attempting to SFTP with the transfer protocol TCP.
    2. Setup QoS (Quality of Service) to restrict the upload data rate in case the data was being sent too fast causing a drop out, used 1Mbps upload.
    3. Firmware update to the latest version for my router in the hope there may have been an internal protocol bug fix.

    None of the above did anything for the problem.  The only very temporary workaround I'm finding is to disable/re-enable the network adapter and that lasts for just a few minutes before the upload hangs but it gets the job done.


    So the essential question is why would resetting the network adapter make any difference? Rebooting the router itself doesn't fix the issue so what is being changed between the computer using the SFTP protocol, the local router and GoDaddy's FTP servers?


    My only non-expert thoughts are when the local computer first connects to the local router there is a "clarity of connection" (whatever that actually turns out to be) that allows the SFTP using TCP protocol to properly negotiate with GoDaddy's servers the first time.  Then after a short time period the local computer to router to GoDaddy server packet exchange loses this clarity of connection.


    Does anyone with a more expert understanding of protocol negotiation have any better informed understanding?  I have tried WireShark and can't see anything, just a non-negotiation of connection and timeout of connection.


    Maybe this is a locally sourced issue but it appears to be affecting a whole bunch of people.  How can we figure out a local versus server based problem?




    Re: Solution: SFTP Upload Issue with Managed WordPress

    I'm so glad you put trying a wired connection!!! You just saved me!


    Thanks again!

    Re: Solution: SFTP Upload Issue with Managed WordPress





    I Have called TECH SUPPORT? 3 times, for SAME ISSUE.




    ARE YOU ON CRACK!?!?!??!?!



    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress



    Don't rain your fire down on me, I'm just trying to find a solution to this problem.  The information I put out there was done with the intention to help resolve or at least workaround the issue.  Take up your issue with GoDaddy directly.

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Ya that was not directed at you at all.
    Only GODADDY
    Solutions I've found:
    1. worked once only :  disable / enable network adapter
    2. worked once : install brand new install of filezilla on different computer (may work more)
    3. wait : worked once

    What did not work.
    1. call support : has not worked and has been a giant waste of time (when usually it is not)
    2. Installing another FTP client on 'same computer'
    3. getting angry and stressed out : did not work

    Have a productive day.
    I am wishing I had the last 4 hours back.

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress



    OK thanks, sorry you are having this issue, its still happening for me too and I'm beyond fed up with having to work around it day-to-day.


    So I have investigated some more (as I get time).  Here is what I have found out about the .NSFxxx temp files that are left on the server once the upload process fails.


    What are .NSF Files and Why they are created?





    Basically according to the above links, under linux/unix, if you remove a file that a currently running process still has open, the file isn't really removed.  So it looks like the upload process is:


    1. Starting the FTP upload
    2. Failing Mid-way (for whatever reason is effecting everyone)
    3. The FTP upload process is left open
    4. The uploaded temporary file is removed (???)
    5. Causing the .NSFxxx file to be left on the server
    6. Having the .NSFxxx file on the server then prevents any future FTP upload connections from being negotiated until you manually clean up the mess

    When I get some time I'll research negotiating FTP server upload protocol negotiation to see if that knowledge gives me any clues.




    Re: Solution: SFTP Upload Issue with Managed WordPress

    Fantastic. Thanks! This finally sorted it

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Hi Everyone,


    I have officially given up trying to use SFTP with Managed WordPress Hosting and simply bypassed the problem by installing a file manager plugin that can upload any and all files at all times without problems.


    Take your pick of file manager plugins from the WordPress repository.



    GoDaddy after nearly six months of trying to make this work my conclusion is that your SFTP file uploads service is unreliable, undependable and quite useless.  The only pattern I can discern is during high capacity time periods it fails to upload and during lesser capacity periods the chances of uploads working are much higher.


    From this observation I am going to suggest that lack of capacity to accept and negotiate good SFTP upload connections via your FTP servers is a factor in the problem.  For why would it work at any time if the negotiated connection was impossible to make via our computers, routers, modem setup?  This is an observed pattern over MONTHS and not just a one off bad ISP router hop connection.


    Downloads have always worked flawlessly at any time of day.



    Re: Solution: SFTP Upload Issue with Managed WordPress

    Hi, Aly,


    I can confirm your conclusion that GoDaddy SFTP with Managed WordPress and Windows 10 has serious issues.


    I am a web developer who has installed hundreds of WordPress sites on  GoDaddy servers, and have no problems with those I install WordPress on Linux CPanel servers which are great, but any site I've built on Managed WordPress suffers the same SFTP problems you describe.


    SFTP will work for a while, but after a while returns "fatal errors" when you try to transfer files, and usually writes the file you are sending onto the server with 0 bytes -- no content in the file now on the server -- which in some cases can crash your WP site if you are uploading something like a WP-Config.php file etc.


    The only way to remedy the problem as you describe is to disable your network adapter in Windows Device Manager and then renable it, after which it will work again for a while until it crashes later in the day.


    It doesn't matter which FTP program you try to use, whether FileZilla, Dreamweaver, etc. the errors are the same. And it doesn't seem to matter which PC or network card I use -- I have tried many -- and I get the same result.  And you can't blame the problem on your ISP or router because I upload files from many locations where my clients are, but I have the same problem regardless of which WordPress site, PC, network card, router or ISP is being used.


    The problem not only affects SFTP transfers, but can also screw you when you are simply using the WordPress Admin to manage or edit your site. When you try to Save a page, you will often get a timeout error and your page isn't saved, and you always lose your work in your WordPress editor when it crashes.  Also, when saving a page or post in WordPress admin does complete successfully, it still takes far longer to send and save the page as it should. It's fast on Linux servers but really slow on Managed WordPress.


    I have called GoDaddy tech support but of course they just blame this on your ISP or network or tell you there's some hardware problem on your PC, even after you tell them you've tried many PCs and ISPs. I have spent days trying to figure out how to change settings in Windows 10 to avoid the problem. It has to be an OS problem because it doesn't matter which program I use to try to SFTP. It is not a network wireless card problem; installing the newest network card doesn't make the problem go away.


    Managed WordPress server data transfer is so unreliable with Windows 10 that I have had to move entire WordPress sites off Managed WordPress and onto Linux CPanel servers just to avoid the problem. There are 0 problems with data transfer or saving pages on CPanel servers at GoDaddy (I have hundreds of sites on them) but every site I've tried to build on Managed WordPress has been problematic, and I have tried a few.


    This problem has been around a long while. I was hoping it has been resolved by now, so I just tried installing a client site on Managed WordPress again, but I am now going to have to move it off Managed WordPress and onto Cpanel because of the data transfer issues.


    You are not alone, Aly.


    Jonathan at AtlantaWebDesignGA.com





    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Hi Jonathan,


    Thanks for giving some confirmation of the same issue that I have been experiencing.  The fact the problem is happening over a wide number of ISP's, operating systems, modem, router combos adds weight to the argument this is not a local user problem.


    OS Specific Issue?

    You have a good thought on the issue being operating system based for as with you, no matter which file transfer client I used the problem was the same.  I wish it were just a Windows 10 OS problem but it also occurs on our Windows 7 OS built computers.


    OS Test on Linux or Mac 

    A really good test is if someone reading this thread is using a Linux based OS or a Mac OSX computer do they have the same SFTP negotiation issues with Managed WordPress Hosting (MWH)?  That would help narrow down if this is OS restricted or a more general problem.


    Any Mac OSX users out there want to give this a try and post their findings?  Apple gear is too expensive for me to buy just for this testing purpose.


    Windows Network Stack Issue?

    Could this be a more general network stack issue with Windows OS computers and the SFTP protocol negotiation being used by GoDaddy's MWH servers? 


    If Windows 10 or 7 computers can consistently negotiate SFTP correctly with cPanel then I am inclined to think there has to be a difference in protocol negotiation and/or ports used that causes the failure with MWH servers.


    SFTP Protocol Negotiation Differences - cPanel / MWH


    What would really help to know is the difference between cPanel and MWH and how those servers are setup to negotiate SFTP on the back-end of GoDaddy.


    If negotiation works one way but not the other can they modify how the MWH servers are configured and so give everyone a permanent solution?



    Re: Solution: SFTP Upload Issue with Managed WordPress

    Never expected this to work, but it did on my Intel NUC's built-in Intel I218-V Ethernet adapter using FileZilla for SFTP.


    I disabled "Energy Efficient Ethernet" in the Device Manager for this device.

    Re: Solution: SFTP Upload Issue with Managed WordPress

    The problem will definitely come back even if you solved it miraculously. Today, I had to contact support who suggested I add.user.ini file to allow large files. His suggestion was pretty useless because the default settings already allow large files and what I needed to upload was just a 26KB css file. The disable/enable workaround helped at very long last.

    I'm also fed up now because besides the file upload problem, saving files edited in WordPress results to errors and IE crashes. Browsing the site also leads to "too many requests error" and some delay in rendering pages - the list just goes on. I spent hours today trying to upload a 26KB file with FileZilla - see how productive?

    I think the sanest step to take right now is to move to cpanel. If that doesn't work well, I would have to move to another provider.

    Anyway, thank you all, for the info. I hope for a better solution soon.

    Re: Solution: SFTP Upload Issue with Managed WordPress

    I confirm I have ALL the same problems as ATLWebDesignGA including those where simple saving in wpAdmin and even browsing the site can occasionally result in "This site can’t be reached" message. I was afraid this was happening for all users accessing the site, but I guess not (or maybe it is, I don't know at this point). So frustrating!


    HOURS spent diagnosing and troubleshooting and HOURS more on the phone with GODADDY net NO SOLUTION.


    Uninstalling/reinstalling my network adapters via Device Manager seems to have mostly resolved the issue (THANK YOU). I can upload files successfully at a higher rate, but nowhere near normal. I do not expect it to maintain.


    Side note - I also have a "VirtualBox Host-Only Ethernet Adapter" in Device Manager Network Adapters. Is anyone else running this, possibly causing conflict? I'm not savvy with this stuff, just a shot in the dark.


    Godaddy Managed Wordpress


    Windows 10
    Netwrok Adapters: Intel(R) Ethernet Connection I218-V
    Realtek PCIe GBE Family Controller

    ISP: ATT

    Re: Solution: SFTP Upload Issue with Managed WordPress

    I too have the same issue, my site has to many redirects errors, SFTP does not work on Filezilla or command line. Tried from different locations & different service providers but makes no difference, the issue/fault is with GoDaddy. Compensation is in order!

    Re: Solution: SFTP Upload Issue with Managed WordPress

    I am also having this issue. I have many sites on godaddy. I have run across this issue, with managed wordpress, once before. So now two of my sites have SFTP issues. This is a server issue with Godaddy. Multiple computers, multiple ISPs, multiple sftp clients, all fail to keep sftp connection.


    When i access another site, i have hosted with godaddy, no problems at all. If your site sits on one of these failed servers, you will have the same issue. 


    My current solution, which is very tedious, is to disconnect from the server EVERYTIME i make an upload or download. Right after it is complete, i disconnect. I dont give the server or the NIC card time to mess up. I initiate the close. Ever since i started doing that, it has not had an issue. If i forget to disconnect, and go back to coding, when i am ready to re-upload, it has a SFTP fatal error again.

    I also reported this thread. Im hoping the moderator will send this link to the Godaddy Tech support team. They dont seem to be paying attention. Also, calling support gets me the same responses as everyone else. No resolution.

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Speed Up Connection

    So I came across what I thought was another good suggestion while reading through these message forums to fractionally speed up connection to a domain.  Even though the idea didn't work the diagnostic trial helps to eliminate one connectivity possibility.


    Local DNS Lookup

    I added our website IP address and domain name to the local computers Windows 10 hosts file as a test to see if time taken for DNS resolution was a factor.




    198.xx.xxx.xx    yourdomainname.com   www.yourdomainname.com

    (Obviously you place your actual domain IP address in the example 198.xx.xxx.xx location).



    The presence of a local hosts file value will override the need for an Internet based DNS lookup.  If a local value exists then that is used first.  This change appeared to work well for an entire day then the next day the same old problems reoccurred.


    I was thinking if speed of domain DNS resolution was a failure factor this test would bypass the issue but it doesn't appear to be involved in the root cause of the problem.

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress



    Thank you for this most valuable insight.  Working off what you have identified I think you may possibly have hit upon a potential root cause of the problem. Here's my theory and I am not a network or server expert but logic can often get you a long way in diagnostics.


    Theory for Failed Connections

    What if the server side routing table(s) that control the SFTP upload sessions are not disconnecting sessions in a timely fashion and/or are not synchronizing with the other servers in the FTP cluster correctly? 




    When your client computer seeks another SFTP session after a variable time period, 30 min / 1 hr / 1 day if the new SFTP session request comes into a DIFFERENT different server (in the cluster) that doesn't have a record of the last SFTP session you had made...




    The new server would check with the other cluster servers asking "Are there any open sessions for this client?"  If the old server had not dropped the session then the new server would say, there already is an open session...




    Fail to establish the new SFTP session...


    (If the connection came into the same server as before it would also have an existing open session showing in the routing tables so reject and fail to establish a new SFTP session.)




    You reset the local client computer network adapter which would possibly generate a new unique identifier for the SFTP server routing table records, therefore forcing a new entry in the routing table and allowing a new session to be initiated.


    TTL (Time To Live)

    There will also be a TTL factor going on in this game, where after X number of hours/days or regularly once a time period that will flush the routing table or drop all sessions older than a certain time period.


    This might explain why after a while you can establish a new SFTP session successfully.


    Different Entry Points

    Another alternative explanation is all the individual servers are maintaining independent SFTP server routing tables and if you try to connect again and keep getting the same server on entry it still thinks you have an active session and deny the new connection


    But if you randomly get a different server entry point then it will create a new entry in its independent SFTP server routing tables allowing a new connection.


    Synchronization of SFTP Routing Tables

    There may be some synchronization between servers in the cluster of the SFTP routing table values every X minutes/hours or they may all be sharing a centralized lookup table.


    Only GoDaddy Knows

    Only the GoDaddy networking team knows how this is setup and these are just my best guesses but I think this theory might explain all the observed symptoms and why a local network adapter reset would "fix" the issue temporarily but not permanently.



    Re: Solution: SFTP Upload Issue with Managed WordPress

    same issues as everyone but nothing worked for me. 


    I read someone said try using a wired connection, and that didn't work so for **bleep**s and giggles I have IP vanish, and I had it turned off thinking that it might cause an issue with uploading. 

    As soon as I turned on IP vanish on and tried uploading it worked .. I will not say this is a fix by any means, but that's what worked for me. 

    Community Manager
    Community Manager

    Re: Solution: SFTP Upload Issue with Managed WordPress



    Thanks everyone for taking the time to look into this and share your issues/resolutions. This can definitely be a frustrating issue. From this end, I can tell you that it is possible (in isolated situations) for the cause of the upload problem to be something on our end. However, it is also entirely possible for the cause to be related to things like network cards, firewalls, and many other variables. Unfortunately, there's no silver bullet for resolving this issue. The key thing to know is that each situation needs to be reviewed on a case by case basis. Here are some common troubleshooting steps you can take to move forward.



    As has been expertly detailed by @Aly and others, there are some network components that can come into play with this situation. These are all excellent troubleshooting steps to try. For some people, they work. However, when they don't, please consider other additional troubleshooting steps.



    This may not be an issue for anyone on this thread, but making sure that you're using the correct protocol and port (SFTP/22 vs FTP/21) are essential in uploading files.


    Session time out


    SFTP sessions do not stay open indefinitely. A good practice is to refresh the directory you're currently in with the client software so the connection can be re-established if it was disconnected. Coming back to a connection that has timed out will cause connection failures.


    Contact Support

    If none of the steps above (including those posted by others) help to resolve the issue, please get in touch with one of our hosting support representatives. Please be sure to let them know you've tried the steps above. Also, I'd recommend having the following information ready:



    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    Re: Solution: SFTP Upload Issue with Managed WordPress

    @JesseW -  I have moved several of my clients to Managed Wordpress and I am experiencing this issue only on one. I have shown this to tech support when I called. There's nothing wrong with your Nic card, nothing wrong the firewall. I am able to connect and upload/download using the same windows 10 PC on several other Managed Wordpress account while I am facing this issue with this one particular account.  

    It seems like tech support is not looking into resolving this issue. 

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    @JesseW @Jdoe09


    Hi Jessee,


    Thank you for the helpful reply and input into the problem.  However at this stage I am going to respectfully disagree with the conclusions being drawn.


    As a long term GoDaddy customer (over 14 years) I know the value of working the system and normally receive a consistently high standard and helpful response from GoDaddy first level tech support who then escalate problems up the line.


    However this is a case where no resolution is being given upon escalation up the line for myself or others.  Each time I or anyone else in this thread has escalated we are told its a local issue even though we are able to troubleshoot and prove that this is not the case.  Obviously the "proof" is in our eyes and not acceptable as evidence to senior level tech supports.


    When over (for myself)) now a 9 month time frame with access from multiple computers, multiple networking access points, multiple rdifferent router hop paths the problem consistently remains the same, I respectfully submit that there is a centralized SFTP upload connection server issue affecting multiple clients and accounts and not localized to the client's computer & networking connection.


    For sure there will be some cases where the issue is localized and network related but when so many people with so many configurations and different gear all receive the same problem symptoms, this provides, to my mind, a considerable weight of evidence towards a centralized issue being the cause.


    I think everyone in this thread feels their problems are not being seriously addressed by GoDaddy.  


    When on the same computer using SFTP to a cPanel account upload works consistently flawlessly but then within minutes using SFTP to a Managed WordPress Hosting account upload fails consistently, this points to MWH as having a SFTP upload protocol negotiation issue.


    None of us as end users can fix this only the networking team at GoDaddy.  At this point there is nothing more I can troubleshoot.  I guess I can research FTP negotiation protocols and play with WireShark packet capture some more but it wasn't showing me anything helpful previously just failed connection information.


    I feel the end users have provided a good weight of evidence that there is a deeper centralized issue that needs to be addressed.  We know that GoDaddy values its service and reputation, the impression it makes with its customers.  Please ask the senior troubleshooting team to look further into the issue.


    If @Jdoe09 can have no issues on several MWH accounts but have a problem with just one MWH account this is evidence that the SFTP upload connection for that one account has an issue unrelated to their client computer and networking setup and router hop connection route.


    Thank you for your consideration of promoting this issue up the line.




    Re: Solution: SFTP Upload Issue with Managed WordPress

    I've had  the same problem for the past 2 months (sporadic SFTP connection and 0Byte uploads).  I'm really tired of calling Tech Support only to have them offer little support.  My ticket has been "escalated" which is a convenient way of getting me off the phone and tp wait another 72 hours with no solution.    Also, tried installing the Wordpress File Manager plugin.  Unfortunately, I cannot edit files with that either.  I asked for a prorated refund so I can move to another service only to be told  the issue is not on their end so they won't provide any refunds or credits.  The Traceroute revealed  packet transfers at  Level 3 which is "completely out of their control" and they have no solution for it.  Unfortunately, I paid for 2 years for this horrible service.

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress


    Another helpful update from @magicman94 in the parallel thread https://www.godaddy.com/community/Managed-WordPress-Hosting/FTP-connected-but-unable-to-transfer-fil...


    Resetting the IPCONFIG settings via a command prompt appears to have the same temporary solution effect as resetting the network adapter card, which makes perfect sense as the two actions are likely doing the same thing.  That is resetting the IP address / connection / port settings on the local computer that I am guessing the GoDaddy SFTP servers are using as a unique identifier to establish the SFTP session with the client.


    Resetting locally would therefore likely force a new (clean) session to be established with the GoDaddy servers.  For a short while the session works until after a time period things get messed up, for whatever reason.  


    The transfers then no longer work, possibly because the session table isn't cleared correctly / dropped on the GoDaddy server side until the local computer IPCONFIG / connection / port reset.



    Re: Solution: SFTP Upload Issue with Managed WordPress

    This problem is happening more and more. I tried your solution. It did not work.  It used to only happen later at night to me. Then it become more periodic. Now it is dominating. It is clear from people posting here that this is a massive problem thats NOT on our end. 


    The other day I went through chat support and once we did a certain amount of troubleshooting and a traceroute and they told me that processes were backed up in the server queue and needed to be cleared out, like other stuck ones that didnt make it through. It worked after that but the problem of course continues. I tried to tell a chat support person today what we went through the other day to reach a solution but they werent having it. 


    This is literally impeding my ability to work. Do we have to switch away from GoDaddy because of this?

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Hi @nikolat


    Sorry my temporary workaround didn't work for you.  Have you tried another way that seems to give temporary relief from the issue?


    On windows computers, launch the CMD prompt (click Windows icon, type "command") then type the following one at a time.  (These commands release the local IP configuration, renew it and flush the local DNS table values.)


    ipconfig /release

    ipconfig /renew

    ipconfig /flushdns


    GoDaddy advises they have escalated the problem and the senior networking group are  currently looking at the issue so we will all have to wait and see what happens.  I don't work for GoDaddy and am just an end-user like you, who offered my suggestions to the community to be helpful.



    Re: Solution: SFTP Upload Issue with Managed WordPress

    I was referring to the permanent fixes relating to power settings. Temporary fixes are not viable for the amount of work that I do. I have setup hosting with another provider, theirs loads much faster and no uploading issues. For web developers, this managed wordpress hosting is not an acceptable product. It was literally stopping my work in my tracks and costing me hours ... days .... not to mention my sanity. 


    Good luck.



    Community Manager
    Community Manager

    Re: Solution: SFTP Upload Issue with Managed WordPress



    Thanks so much to all of you for participating in this thread. We were finally able to identify a small configuration change that we were able to put into effect to help with this situation. Basically, we had to allow smaller blocks of data to be transmitted, which allowed a more stable connection. That should resolve a majority of what you were all seeing. However, please don't hesitate to reach out to our support team if you continue to have this issue. 


    Special thanks to @Aly for helping us identify and troubleshoot the issue Smiley Very Happy


    JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Upon seeing an email that the latest reply had been accepted as a solution, I purchased another managed wordpress hosting account to try it out since I have a new site to setup. I am in a different area of the country right now than where I normally work - so I know the local connection can't be blamed. 


    After a few hours of work, I have still encountered the issue - though only a few times in a few hours as opposed to constantly (where file uploading fails and shuts down the software). Unfortunately the loading times, as well as backend loading & saving of pages/posts/changes, are still slow and sluggish compared to other hosters, not to mention the saving issues present the same problems as when the stylesheet doesn't fully upload.

    Right now the only advantages I can see to the Godaddy wordpress hosting is how cheap you can get it when there are coupons, and the site importing feature. However the slow loading will continue to motivate me to migrate all my freelance accounts and all of my agency's accounts to another provider.

    I hope Godaddy can get this service up to speed with their competitors, because I would really love to manage everything in one place, but for now, this is still not an acceptable solution for web developers. 

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Hi Jesse,


    Thanks for your help @JesseW and GoDaddy's networking team for working with us on this frustrating issue. 


    For the record on this thread, I confirm that I tested the changes out for three weeks and didn't have a single issue now uploading via SFTP after the server cluster changes were applied.


    Regarding the experience @nikolat just wrote about. 


    Have the server changes that were applied to the cluster I was on been rolled out globally to all the WordPress Managed Hosting server clusters?  That might explain why the problem is appearing on a non-patched server.

    However if the server changes have indeed already been rolled out to nikolat's server cluster then I sadly know no answer to the SFTP upload issue.


    For me now finally things are working and looking good without a single error during three weeks of testing, a miracle given the past year long challenges of every 30 min or so needing to reset my network adapter to upload (can be longer, half a day, full day working).


    I'm grateful and now I hope a community wide solution can be found.



    Re: Solution: SFTP Upload Issue with Managed WordPress

    @Aly I just realized you're not with GoDaddy and that you have just been doing a lot to try and make this work. Thank you. 

    @JesseW Id like to remind you that about a month ago you said "From this end, I can tell you that it is possible (in isolated situations) for the cause of the upload problem to be something on our end. However, it is also entirely possible for the cause to be related to things like network cards, firewalls, and many other variables. " .... In case you have not noticed, tons of customers have been frustrated to the point of madness not to mention had their jobs and clients jeopardized by this hosting product. We all were insisting that it was not a problem with our individual connections and machines. This problem, which still exists just not as bad, was/is costing many people time and money. It was disappointing to see no apology or mea culpa from GoDaddy's end when you finally admitted that the problem is on GoDaddy's end. If I wasn't so busy catching up on all the time I lost dealing with this product,  I would help get a class action lawsuit started for this Micky Mouse Managed Wordpress Hosting account that runs about as fast as the train at Disney World. 

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Just an update for those of you still looking for an answer. I resolved this issue by bypassing my firewall and sure enough it worked. I just disconnected it and used an old router  this solved this issue for me, hope this helps someone.

    Now im having an issue with the password being wrong !!!

    Back to work

    Helper III
    Helper III

    Re: Solution: SFTP Upload Issue with Managed WordPress

    Hi @qbwankenobi


    Sorry to hear you are still having a long term problem with this issue and glad you found a temporary workaround for now.


    Since posting this issue and having the server cluster my site is hosted on reconfigured, by GoDaddy's networking team, to accept smaller data packet sizes, I haven't had a single SFTP upload issue, not even once.  Frankly I find that amazing after over a year's worth of grief and a good indicator that data packet size may well have been the root cause of the connectivity issue.  Why I have no idea but it seems to have done the trick now for a good number of trouble free months.


    I'm wondering if this change was rolled out to all the server clusters on the Managed WordPress Hosting platform?  I can only assume it was as this is what they told they were going to do.  However it might be worth a tech support inquiry to find out.


    I know this isn't a solution for you but I did want to give fair feedback on the issue.  There may well be other issues at play here affecting your own hosting situation.



    Re: Solution: SFTP Upload Issue with Managed WordPress

    Cant believe this issue is still happening. This product is a an utterscam. Turning off your firewall as @qbwankenobi did is NOT a solution. 


    It has been 3 months since @JesseW  declared the problem sort-of-solved, but it is in fact persisting (not to mention @JesseW  first blamed this on all the users and has still yet to acknowledge that was a mistake)


    If anyone would like to join me in talking to law firms about a class action lawsuit, please reply here and let me know.