cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PHP shared hosting site all of a sudden started showing ionCube error and the support not helping

Hi, I have an issue with my site http://www.trucks2cars.com/search-cars.php

It was working fine for 10 yrs. and all of a sudden started showing ionCube loader installation error! I didn't even accessed or modified the site for a long. But the customer care executives are asking me to review my code and installation of ionCube! I followed all their instructions and reinstalled ionCube loader as per the help article! still it is not working! They are again and again asking me to review it even though I didn't change anything and the error happened by some change in server!?

I tried everything I can! I don't know what to do now!? Please help!

Thanks,

Palz

4 REPLIES 4
Community Manager
Community Manager

Re: PHP shared hosting site all of a sudden started showing ionCube error and the support not helpin

Hi @PalZone. Thanks for being part of GoDaddy Community! I'm not sure why this would happen all of the sudden, but the error on your site does look like there's an issue with the way ionCube loader is being referenced. The most common mistake is not including the code at the beginning of your PHP initialization file (php5.ini in your case) as is indicated in this Help Center article. You can share the script of your file here and others may be able to point you in the right direction. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

Re: PHP shared hosting site all of a sudden started showing ionCube error and the support not helpin

Thank you @JesseW for the reply. I already followed the help centre article and re-installed the ionCube loader. I have included the code at the beginning of your PHP initialization file php5.ini. But, still not working. My major concern is about starting this issue all of a sudden! That's why, I suspect some change in the server causing the issue! But unfortunately, nobody from technical support is ready to help by debugging it! 

By the way, here is the php5.ini file content:

 

[Zend]
zend_extension=/home/content/94/10111494/html/ioncube/ioncube_loader_lin_5.4.so
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3
zend_extension=/usr/local/Zend/lib/Optimizer-3.3.3/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3/ZendExtensionManager_TS.so

 

register_globals = off
allow_url_fopen = on
allow_url_include=On
display_errors = on

expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
apc.enabled=0
extension = mod_rewrite.so

 

; Only uncomment zend optimizer lines if your application requires Zend Optimizer support

; -- Be very careful to not to disable a function which might be needed!
; -- Uncomment the following lines to increase the security of your PHP site.

;disable_functions = "highlight_file,ini_alter,ini_restore,openlog,passthru,
; phpinfo, exec, system, dl, fsockopen, set_time_limit,
; popen, proc_open, proc_nice,shell_exec,show_source,symlink"

 

magic_quotes_gpc = Off
magic_quotes_runtime = Off
magic_quotes_sybase = Off

Community Manager
Community Manager

Re: PHP shared hosting site all of a sudden started showing ionCube error and the support not helpin

@PalZone - I would make sure you don't have any other PHP initialization files in the account. Also, after making a change to your PHP settings, you'll want to make sure you kill any PHP processes that are running. 

 

JesseW - GoDaddy | Community Manager | 24/7 support available at x.co/247support | Remember to choose a solution and give kudos.

Re: PHP shared hosting site all of a sudden started showing ionCube error and the support not helpin

No, there is no other init file and I always end all processes after making changes. I'm a software engineer with more than 15 yrs of experience. It is difficult to fix something just by some guess work, as there is no option for me to find any error or debug! Now, it is impossible for me to fix it without any help from the technical/server team. But as I said earlier, they are not ready to even look into this issue, presuming that it is something on my side is causing this issue.

 

Happening this all of a sudden itself is a sign of some issue from the server side. Something got changed for sure! It can not be happen just like that, right? Is it a magic? I don't get the support team's logic! How pathetic!

 

Any now, I have decided to move on and move to another good hosting provider, who promise me a better support.

Thank you for your help. Please fwd this issue to your technical team if possible! I'll be waiting for few days more before I move the services. I'm asking for a last time for help as I have to move a lot of sites from the server. It's a pain.

 

Thanks and Regards,

Pals