cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Go to solution
Highlighted

How to set PHP Time and Max Input?

Dear Godaddy,

I use PHP 5.4 and I want to set PHP Time Limit "max_execution_time = 300" and PHP Max Input Vars "max_input_vars = 3000" and WP Memory Limit to 64M. How to do that? Thanks

12 REPLIES 12
Moderator
Moderator

Re: How to set PHP Time and Max Input?

Hey @engchimmeng

 

Welcome to the community! Smiley Happy

 

This is usually done through modifying a custom .ini file. The most common file name used in our cPanel shared hosting plans would be '.user.ini' which you'll need to create with your modified PHP settings and upload into the root directory of your hosting plan to take effect. 

 

CG - GoDaddy | Community Moderator
24/7 support available at x.co/247support

Re: How to set PHP Time and Max Input?

Best Support. Problem solved. Thanks

Re: How to set PHP Time and Max Input?

Worked

New

Re. Https://Uk.Godaddy.Com/Community/Managing-Web-Hosting/How-To-Set-PHP-Time-And-Max-Input/M-P/1709

have EXACTLY same problem with that link. Unfortunately, it does not solve my problem.

 

I put user.ini at root of the folder, with:

 

max_input_vars = 10000;

max_execution_time = 36000;
memory_limit = 64M;

 

What I really need is the max_input_vars.

 

Thanks for kind reply.

 

 

New

Re: Re. Https://Uk.Godaddy.Com/Community/Managing-Web-Hosting/How-To-Set-PHP-Time-And-Max-Input/M-P/

Ok this was solved by CG!

 

Thank you CG!

Re: Re. Https://Uk.Godaddy.Com/Community/Managing-Web-Hosting/How-To-Set-PHP-Time-And-Max-Input/M-P/

Is this the same for Wordpress managed hosting?

 

As I do not have an .ini file present.

Re: How to set PHP Time and Max Input?

This solution is not working for us...

Re: How to set PHP Time and Max Input?

any one can help for modify the php limits.

  • Memory Size: memory_limit = 256M
  • Script execution time: max_execution_time = 400
  • Number of input variables: max_input_vars = 10000
  • Php upload limit: upload_max_filesize 64M
  • Connection time limit: max_input_time = 3600

i try all and still the  max file and post not changing.

 

am using word press theme and not working.

New

Changing var limit - prestashop

Hello,

I have a problem with translation, I have maximum allowed 1000, but I need atleast 1500.

I already tried to add php.ini with this code: max_input_vars = 5000

Also I tried to add .user.ini with the same code but it is not working. The last thing I tried was to follow this video: https://www.youtube.com/watch?v=tdUlIkZcOe0

None of these tips helped me. I have Prestashop and Cpanel.

Thanks in advance for help

Solution

Re: How to set PHP Time and Max Input?

I chatted with GoDaddy Support and got the following solution when using cPanel:

 

1 - Connect to and login to cPanel.

2 - Choose "Select PHP Versions" from the "Software" section.
3 - Click on "Switch to PHP Options" on the right side of the page.
4 - Select each number for desired PHP parameters that you want
      to change then choose the largest size in the drop down menu.

5 - Apply each change.

6 - Save the changes.

The following parameters are available:

allow_url_fopen              On
display_errors                 Off
error_reporting                E_ALL
file_uploads                     On
include_path .:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php
log_errors                        On
mail.force_extra_parameters     no value
max_execution_time       120
max_input_time                  -1
memory_limit               128M
open_basedir          no value
post_max_size              32M
session.save_path        /tmp
short_open_tag               On
upload_max_filesize     32M

 

New

Re: How to set PHP Time and Max Input?

Solved the issue following the solution provided by DBL1955

Didn't know about this features available within the "Select PHP version" section.

Regards!

 

New
Solution

Re: Re. Https://Uk.Godaddy.Com/Community/Managing-Web-Hosting/How-To-Set-PHP-Time-And-Max-Input/M-P/

Hi, I saw this thread and want to add this for those looking - 

 

You don't need the ; symbol - it is designed for comments. I added all the commands, one on each line pressing enter each time. It worked first time on Godaddy Managed Wordpress product by uploading .user.ini to the html folder.